Page 1 of 1

AffinityMask Flag Causes Crash To Desktop

Posted: Sun Feb 17, 2019 12:08 pm
by gollum65
I thought I'd post this info for Eaglesoft to know about it, plus anyone else who is having a similar problem. I have the following:

FSX Steam Edition
Windows 10
I7 7700HQ (4 physical cores, 8 logical)
Logitech Extreme 3d Stick

This week I purchased two Eaglesoft aircraft, the Cirrus SR22 (generation 2) and the Beechjet Hawker 400A/XP (Generation 2). I also have applied the following tweaks to my fsx.CFG file:


Every aircraft in my library, including the ESDG SR22, worked fine with these settings. The only problem I'm having with the SR22 is related to the F1 GTNs, which I posted below.

But when I purchased and installed the ESDG Beechjet 400A/XP I couldn't get the aircraft to load. I set everything up on the free flight page, and when I hit "Fly Now!", I would get a blank loading screen for about 30 seconds, then FSX would crash to the desktop. The small "loading" popup, with the ! in a dialog bubble would come up, but the loading bar itself would never start and the sim would CTD after about 30 seconds.

So I tried to uninstall and reinstall the ESDG Beechjet, but that didn't help. Then I decided to delete the fsx.CFG completely to force FSX to create a new one, and when I did that the aircraft loaded!

So I knew it had to be a .cfg issue, so I started adding the tweaks above, one by one, to find out if any of them were causing the problem.

Sure enough, the AffinityMask=84 tweak caused the same problem to occur. If I went back and removed the tweak, the plane loaded again. Then I changed it to AffinityMask=14 and the plane still loads fine, along with all the other tweaks listed.

Note from my specs that I DO have a quad-core processor with hyperthreading enabled (4 physical cores, 8 logical), and AffinityMask=84 IS the correct flag for that configuration, but for whatever reason, the ESDG Beechjet 400A/XP won't work with it. When I changed to AffinityMask=14, which is the flag for a quad-core processor WITHOUT hyperthreading, the aircraft loads fine.

It might have only been a problem specific to my system, but I thought it was worth pointing out.

Re: AffinityMask Flag Causes Crash To Desktop

Posted: Sun Feb 17, 2019 12:41 pm
by N400QW
First thanks for posting. It should be noted that the BJ 400 is an older AC produced before Steam Came along. Best to fly is with default settings or whatever works best w/your system.

We are looking at solutions for the GTN popup powered off issue as mine here have recently shown the same issue ;)

Re: AffinityMask Flag Causes Crash To Desktop

Posted: Mon Feb 18, 2019 10:15 am
by gollum65
Well, I guess I spoke too soon. :( Even though I LITERALLY haven't even opened FSX since I got the aircraft to work, then came and wrote my post above, now I can't get either model of the aircraft to load at all. It doesn't matter if I delete the fsx.CFG and have the simulator make a new one or not. It just won't load under any circumstances.

Any advice or tips? I know you said this aircraft pre-dates FSX SE, but I don't know that it would matter that much? And even if I have a set of discs from the original boxed FSX, which I'm sure I do somewhere, I don't even have a DVD drive on my computer. So I couldn't install it even if I wanted to.

Re: AffinityMask Flag Causes Crash To Desktop

Posted: Tue Feb 19, 2019 12:54 pm
by N400QW
The readme file contains clear instructions on the loading conditions. Try those and report back.