CJ1+ Issues

Citation CJ1+ Extreme G2 Support Forum
Post Reply
User avatar
N400QW
Site Admin
Posts: 458
Joined: Tue Sep 05, 2017 12:02 am
Location: Midwest
Contact:

CJ1+ Issues

Post by N400QW » Wed May 15, 2019 6:32 am

keeska wrote:
Wed Jul 11, 2018 8:46 pm
Sorry I just noticed I posted in the incorrect forum. Should I move this to the CJ1+ forum?

After flying the Citation X for a couple of years I thought I'd like to try another Business Jet so I purchased the CJ1+. I am please with it but have some questions:

1. Is there a tutorial describing how to use the A/P?
I am having problems with FLC oscillating between dive and climb. I engaged FLC when at 210 kts in a climb with the speed set for 210.

On an ILS APP mode descends when the G/S is 3 dots high. I was level at 5000 with ALT engaged. I hit the APP button. It captured the LOC and turned onto the inbound track. As soon as it was on the inbound track the airplane started a slow descent with the Green G/S dot still 3 bars above center.

2. Is there a TO/GA button?

3. When loading the airplane I connect the GPU and then shut down the engines using the click spot below the throttles (save fuel :-)). When I am ready to start the engines I hit Engine start for the right engine. I then use the same click spot to move the throttle to idle. But the engine does not start. It runs up to a bit above 20% N2 and then it stops trying to start the engine. I discovered that I need to use the FSX CTRL-Shift-F4 key combination to move the mixture out of cutoff. Isn't that what the clock spot should have done?

FSX Gold on Windows 7
I downloaded the CJ1+ installer a week ago so expect I have the latest version.
Best Regards,
Ronald Hamilton ASEL

Image

Post Reply