CXG2 FMS Navigation

Citation X Extreme G2 Support Forum
Post Reply
joneill4094
Posts: 9
Joined: Tue Jan 23, 2018 11:59 pm

CXG2 FMS Navigation

Post by joneill4094 » Mon Jan 29, 2018 12:07 am

Hello again!
At the risk of asking another question that reveals me doing something stupid, I need a little assistance. I've been having issues with FMS Navigation in the Citation X 2.0. I have the flight plan loaded in, no discontinuities, per init and all that complete. I checked the tutorial videos and made sure I was following their procedures. However, when I get airborne, my plane will not follow my flight plan. It will fly to the first waypoint, but afterwards will go off in a random direction or start trying to fly a circle around the waypoint. I have to manually click "direct to" and select the next waypoint every time I arrive at a waypoint. I have FMS1 navigation selected.

One thing I noticed is that all the videos I watched have a magenta line over the HSI, just like for VOR navigation, when FMC1 is selected. In my case, I do not have that nor can I figure out what I'm doing wrong. I did exactly what one of the tutorial's did, click for click, but his magenta line appeared and mine did not. See the pictures below for further:

FMS button pressed, without FMS1 selected under "BRG":

Image

With FMS1 selected under "BRG":

Image

As you can see in the picture, I also get an error on the FMC stating "Check Data Load 264."

I am running on P3D V3 on Windows 7. The problem exists on any routes, from real world routes with sid/star's and approaches, to a simple one waypoint flight plan like above. The plane just WILL NOT follow the FMS.

Any ideas guys?

Thanks!
John

WarpD
Posts: 232
Joined: Mon Sep 11, 2017 6:26 pm

Re: CXG2 FMS Navigation

Post by WarpD » Mon Jan 29, 2018 5:34 am

You didn't "close" the flight plan. The final waypoint in the flight plan absolutely must be the destination.
Best Regards,
Ed Wilson [WarpD]

Image

aua668
Posts: 8
Joined: Wed Sep 13, 2017 4:50 pm

Re: CXG2 FMS Navigation

Post by aua668 » Mon Jan 29, 2018 9:46 am

Hi,

As far as I remember, this "check data load 264" message is a small bug, which you can ignore. In the old forums (before the crash) there have been several reports about that. The comment at that time was: "ignore it please, we will fix it in future releases/patches".

Rgds
Reinhard

joneill4094
Posts: 9
Joined: Tue Jan 23, 2018 11:59 pm

Re: CXG2 FMS Navigation

Post by joneill4094 » Thu Feb 01, 2018 10:19 pm

WarpD wrote:
Mon Jan 29, 2018 5:34 am
You didn't "close" the flight plan. The final waypoint in the flight plan absolutely must be the destination.
That solved it. Thanks WarpD!

Post Reply