CXG2 IRS won't Align

Citation X Extreme G2 Support Forum
Post Reply
waymon
Posts: 4
Joined: Fri Jan 19, 2018 7:46 pm
Contact:

CXG2 IRS won't Align

Post by waymon » Tue Jan 23, 2018 5:22 pm

Ok here's my problem I start with a cold dark cockpit. Turn on power start the APU then turn the mode select switch to NAV then I wait the 5 minutes instead of the system coming on the Align lights just start blinking even when I push the test button I get the same thing.
I can't figure out what's causing this problem. I had this aircraft in FS9 and had no problem with it. Any help I get will be greatly Appreciated.

system: Windows 7 Ultimate 64 bit
Processor AMD FX-8350 Eight core @ 4.00GHZ
RAM 16 GB
Graphics card : Radeon RX 560 series

WarpD
Posts: 180
Joined: Mon Sep 11, 2017 6:26 pm
Contact:

Re: CXG2 IRS won't Align

Post by WarpD » Tue Jan 23, 2018 6:16 pm

Uh... that's normal.

You need to follow the checklists (including all the FMS steps).
Best Regards,
Ed Wilson

Image

maartenvd84
Posts: 5
Joined: Fri Jan 19, 2018 5:19 am
Contact:

Re: CXG2 IRS won't Align

Post by maartenvd84 » Thu Jan 25, 2018 2:12 pm

I had the same thing... It's indeed just a matter of not forgetting to load in the FMS the GPS position (or another one). You should see 'loaded' on-screen.

waymon
Posts: 4
Joined: Fri Jan 19, 2018 7:46 pm
Contact:

Re: CXG2 IRS won't Align

Post by waymon » Thu Jan 25, 2018 5:11 pm

maartenvd84 wrote:
Thu Jan 25, 2018 2:12 pm
I had the same thing... It's indeed just a matter of not forgetting to load in the FMS the GPS position (or another one). You should see 'loaded' on-screen.
Thank you!

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest